Считывание чисел с консоли в Python

Напишите программу, которая считывает с консоли числа (по одному в строке) до тех пор, пока сумма введённых чисел не будет равна 0 и сразу после этого выводит сумму квадратов всех считанных чисел.

Гарантируется, что в какой-то момент сумма введённых чисел окажется равной 0, после этого считывание продолжать не нужно.

ch =  int(input())
sum_kv = 0  #переменная для хранения суммы
sum_kv += ch * ch
sum = 0
while True:   # используем бесконечный цикл
  sum += ch
  if sum == 0:  
        print(sum_kv)
        break   #печать результата и выход из цикла
  else:
        ch =  int(input())
        sum_kv += ch * ch
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: