Треугольник Паскаля — полный вывод

На вход программе подается натуральное число n. Напишите программу, которая выводит первые n строк треугольника Паскаля.

Формат входных данных
На вход программе подается число n (n≥1).

Формат выходных данных
Программа должна вывести первые n строк треугольника Паскаля, каждую на отдельной строке в соответствии с образцом.

def pascal(row):
    current_row = [1]
    for _ in range(row):
        print(*current_row)
        current_row = [sum(x) for x in zip([0] + current_row, current_row + [0])]

pascal(int(input()))


Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: