Вывод позиции числа в строке. Python

Напишите программу, которая считывает список чисел lst из первой строки и число x из второй строки, которая выводит все позиции, на которых встречается число x в переданном списке lst.

Позиции нумеруются с нуля, если число x не встречается в списке, вывести строку «Отсутствует» (без кавычек, с большой буквы).

Позиции должны быть выведены в одну строку, по возрастанию абсолютного значения.

Ответ:

В цикле перебираем все элементы строки sp, сравнивая с числом ch. При совпадении сразу вывод на печать. Переменная log для фиксации совпадения, если значение остается False — выводится ‘Отсутствует’.

Код в python:



sp = [int(i) for i in input().split()]  
ch = int(input())
log = False   #наличие числа в строке 
for i in range(len(sp)):  
    if sp[i] == ch:
        print(i, end=' ')
        log = True
if log == False:
    print ('Отсутствует')


Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: