Работа с элементами списка в Python

Напишите программу, на вход которой подаётся список чисел одной строкой. Программа должна для каждого элемента этого списка вывести сумму двух его соседей. Для элементов списка, являющихся крайними, одним из соседей считается элемент, находящий на противоположном конце этого списка. Например, если на вход подаётся список «1 3 5 6 10», то на выход ожидается список «13 6 9 15 7» (без кавычек).

Если на вход пришло только одно число, надо вывести его же.

Вывод должен содержать одну строку с числами нового списка, разделёнными пробелом.

Код:

sp = [int(i) for i in input().split()]
if len(sp) == 1:   #если строка с одним символом
    print (sp[0])
else:
    for i in range(len(sp)):   #вывод нового списка
        if i == 0:  #первый элемент исходного списка
            print ((sp[1] + sp[-1]), end=' ')
        elif i == len(sp) - 1:    #последний элемент
            print ((sp[i - 1] + sp[0]))
        else:            #остальные
            print ((sp[i - 1] + sp[i + 1]), end=' ')

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: